FishEye, Crucible 4.4 버전이 릴리스 되었습니다. 자세한 사항은 FishEye 4.4 릴리스노트 를 참조하십시요..
페이지 트리
메타 데이터의 끝으로 건너뛰기
메타 데이터의 시작으로 이동

문제

After upgrading to JIRA Service Desk 3.2.0, observe the problems below while browsing a Service Desk project.

  • The project navigation bar will not render properly with message Unable to render element due to an error on top of the bar.

  • Restricted to view any Service Desk related administration settings: Request typesRequest securityPortal settingsSatisfaction settingsEmail requestsKnowledge baseSLAs and Automation.


The following appears in the atlassian-jira.log 

 

2016-08-30 22:12:51,923 http-nio-8320-exec-11 ERROR anonymous 1332x78x3 8rur7t 0:0:0:0:0:0:0:1 /browse/DESK [c.a.p.webresource.assembler.DefaultWebResourceAssembler] Error generating bigpipe content for 'sidebar-id': java.lang.NullPointerException
java.util.concurrent.CompletionException: java.lang.NullPointerException
	at java.util.concurrent.CompletableFuture.encodeThrowable(CompletableFuture.java:273)
	at java.util.concurrent.CompletableFuture.completeThrowable(CompletableFuture.java:280)
	at java.util.concurrent.CompletableFuture$AsyncSupply.run(CompletableFuture.java:1592)
	at com.atlassian.jira.plugin.bigpipe.PrioritizedRunnable.run(PrioritizedRunnable.java:31)
	at com.atlassian.jira.plugin.bigpipe.BigPipeService.lambda$executeSingleTask$1(BigPipeService.java:59)
	at java.util.Optional.map(Optional.java:215)

 

진단

Diagnostic Steps

The following appears in the atlassian-servicedesk.log 

 

2016-08-30 22:10:07,438 UpmAsynchronousTaskManager:thread-1 ERROR anonymous 1332x78x3 8rur7t 0:0:0:0:0:0:0:1 /rest/plugins/1.0/available/featured [atlassian.servicedesk.bootstrap.lifecycle] '2.3.6' version of Service Desk cannot be upgraded to '3.2.0-038-01'. Upgrade to '3.0.0' <= <version> < '3.2.0' first. com.atlassian.servicedesk.bootstrap.upgrade.UnsatisfiedVersionRequirementException: '2.3.6' version of Service Desk cannot be upgraded to '3.2.0-038-01'. Upgrade to '3.0.0' <= <version> < '3.2.0' first. at com.atlassian.servicedesk.bootstrap.upgrade.UpgradeRequirementsChecker.checkVersionRequirementForUpgrade(UpgradeRequirementsChecker.java:25) at com.atlassian.servicedesk.bootstrap.lifecycle.PluginLifeCycle.checkAndRunUpgrades(PluginLifeCycle.java:256) at com.atlassian.servicedesk.bootstrap.lifecycle.PluginLifeCycle.runPluginStartupSideEffectsImpl(PluginLifeCycle.java:183) at com.atlassian.servicedesk.bootstrap.lifecycle.LifecycleLock.writeImpl(LifecycleLock.java:97) at com.atlassian.servicedesk.bootstrap.lifecycle.LifecycleLock.runOnStartup(LifecycleLock.java:75)

 

원인

Unfulfilled upgrade requirements. The minimum version to upgrade to JIRA Service Desk 3.2.0 is 3.0.0, this has also been stated in the upgrade notes.

해결방법

Upgrade to at least JIRA 7.0 with Service Desk 3.0 before upgrading to JIRA 7.2.0 with Service Desk 3.2.0.

  • 레이블 없음