페이지 트리
메타 데이터의 끝으로 건너뛰기
메타 데이터의 시작으로 이동

 

증상

The following appears in the atlassian-jira.log:

2013-10-29 10:39:01,536 http-bio-8080-exec-13 WARN rmartin 639x698x1 hx2ngy 192.168.3.77 /rest/plugins/1.0/com.atlassian.servicedesk-key [plugin.osgi.factory.OsgiPlugin] Because of this exception
com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.servicedesk

...
Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle com.atlassian.servicedesk [113]: Unable to resolve 113.0: missing requirement [113.0] package; (&(package=javax.mail.internet)(version>=1.4.5)(!(version>=6.0.0)))

진단

You have possibly followed the instructions from this KB to use the 1.4.1 version of the mail .jar file.

원인

Service desk needs the mail .jar file to be at least in the version 1.4.1 and JIRA to be at least in 6.0.

해결방법

  1. Upgrade JIRA at least to version 6.0
  2. Use the mail-1.4.5.jar instead of mail-1.4.1.jar.
  3. If you are facing the problem from the KB listed in the "Diagnosis" section above, create an SMTP Relay in your Exchange so the original problem from the KB does not occur. With this fixed, you won't need to downgrade the mail jar to version 1.4.1 and use the required version (1.4.5).

관련내용

 Expand to see related content
Unknown macro: {dynamiccontentbylabel}
Help us improve!
  • 레이블 없음